Compartir

Apple presume siempre de tener un sistema operativo invulnerable, aunque es inevitable la existencia de alguna puerta trasera que aprovechan los hackers para intentar hacerse con la información de los usuarios. Patrick Wardle recientemente ha demostrado en la conferencia Def Con de Las Vegas la existencia de una vulnerabilidad 0-day en macOS High Sierra.

Descubierta una nueva vulnerabilidad 0-day en High Sierra

Patrick Wardle, ex-empleado de la Agencia de Seguridad Nacional de EEUU ha demostrado recientemente que macOS High Sierra es vulnerable a los “clics sintéticos”, algo que puede ser aprovechado por los hackers para acceder a zonas que están protegidas con contraseña.

macOS High Sierra en mac

Todos somos conscientes de que macOS High Sierra tiene un gran abanico de funciones de accesibilidad para aquellas personas que lo requieran. Es por esto que podemos hacer clic sin necesidad de tocar el trackpad o un ratón, por lo que no hay un acto físico, sino que lo hace todo el software.

Según Patrick Wardle estas facilidades se pueden volver en contra de los usuarios, ya que el software puede ser hackeado haciendo que estos clics sintéticos autoricen la entrada al llavero de contraseñas o se autorice a una aplicación que no es de confianza a instalarse en nuestro Mac.

Esto obviamente será una amenaza para aquellos usuarios que no estén atentos a su ordenador y a los cuadro de diálogo que puedan surgir en la pantalla. Aunque este experto en seguridad se hace la pregunta de si es posible que estos cuadros de diálogo estén ocultos y se empiecen a autorizar procesos sin nosotros percatarnos aunque estemos delante de nuestra pantalla.

Como decimos, este error puede llegar a ser muy grave ya que pondría en peligro nuestras contraseñas que tenemos almacenadas en el llavero y por tanto nuestra información personal. Nosotros te recomendamos ver la presentación de este experto aquí, y también cabe destacar que desde Apple ya han parcheado este problema en macOS Mojave que se encuentra actualmente en beta, pero el error persiste en High Sierra.

Déjanos en la caja de comentarios qué opinas de esta vulnerabilidad 0-day que se ha presentado en High Sierra.